RhapsodyGuru

Customizing Rhapsody - Writing Helpers



Contents

Overview: Rhapsody Helper APpPliCAtions........cccceieercnricsssniicsssnnrcsssnsrcsssnssecsssnns
Task 1: Writing a Helper APplication........eeeeccesicrnnriccssssnnnniccssssnssssccsssnsssssscs 3

Task 2: Create Rhapsody Helper Menu Entry.........ccceicciicerccncnnecsscnnnecscnnnneees



| Overview: Rhapsody Helper Applications |3

Overview: Rhapsody Helper Applications

Helpers in Rhapsody are programs, that you attach to IBM® Rational® Rhapsody® to extend its functionality. They
can be either external program or in Java written Application that use the Rational Rhapsody API. Helpers may be
invoked manually from the Tools menu, or automatically, based on some event, for example ‘before saving’.

These Java written Application that use the Rhapsody API can be created as:

When invoked the helper loads, runs as an external
program and when it has done its job it terminates.

Standalone applications

Plug-ins Loads when the Rhapsody project loads. When invoked,
it runs as part of the Rhapsody process. Only unloads
when Rhapsody terminates.

In this short abstract we're going to the necessary steps to write a little helper, which can be invoked from the
Rhapsody Browser. Our helper will extend Rhapsody functionality by locating the current the Active Component
in the browser hierarchy. This missing Rhapsody feature is helpful, especially when you have to deal with bigger
projects and nested browser hierarchy.
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Figure 1: Locate Active Component in Browser

Task 1: Writing a Helper Application

Extending Rhapsody functionality by writing your own application is no rocket sine: A running Rhapsody instance,
Eclipse and Java SDK Environment are the initial ingredients that you need to get started.
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Figure 2: Three ingredients to customise and extend Rhapsody
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Make sure that you have the latest Eclipse release installed on your machine, To avoid any issues make sure that the
Rhapsody and Eclipse Bit-Version is consistent. Mixing the "Bit-Version" might result in unintended and unexpected
behaviour. You can comibine>

* Rhapsody-32Bit with Eclipse-32Bit or
* Rhapsody-64Bit with Eclipse-64Bit
In this Task we will create an Eclipse Project and using the Rhapsody API to write our own Helper Application

1. Launch Eclipse and create project:
a) Launch Eclipse
b) Chose c:\TrainingTools\ as WorkSpace
& coipe '
| Select a directory as workspace

Eclipse IDE uses the workspace directory to store its preferences and development artifacts.

Workspace: | C\TrainingToals\, ~ ‘ Browse...

Figure 3: Eclipse Launcher
¢) From the Eclipse menu select File > New > Java Project

£ TrainingTool - Edlipse IDE
File

New » (& Java Project

Figure 4: New Java Eclipse project
d) Name the project RhapsodyHelpers

£ New Java Project O X
Create a Java Project - JIJ_
Create a Java project in the warkspace or in an external location., {f f

Project name: | RhapsodyHelpers |

Use default location

CA\TrainingTools\RhapsodyHelpers Browse..

_IDE. P,.-.l*‘ o OSSN S CWp PrS r‘ S N

(?3' < Back Finish Cancel

i

Figure 5: Project Name: RhapsodyHelpers
e) Click Next>

2. Java Settings - Referencing the Rhapsody Java API:

For each new project in Eclipse you must specify in the Java Build Path:

* The location of the Rhapsody API JAR (Rhapsody.jar)
* The location of the Rhapsody Native Library (Rhapsody.dll)

a) In Java Settings Window select the Libraries tab
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£ New Java Project O pet

Java Settings B_

Define the Java build settings.

(# Source [= Projects “5 Order and Export

JARs and class folders on the build path:
=4 JRE System Library [JavaSE-1.8] Add JARs...

|L Add External JARs...

Add Variable...

Figure 6: Project Configuration - Libraries Tab
b) Click Add External JARs...

¢) Select rhapsody.jar from \Share\JavaApi directory.

(* Source 1= Projects B Libraries % Order and Export
JAR= and class folders on the build path:

» ma rhapsody.jar - C\Rhapsody'8.3.1'5hare'JavalPl Add JARs...

» B, JRE System Library [jdk1.8.0_172]
Add External JARs...

. & il tomis . f-n' Bt tie ok it f - - | . _.P" -a__:_.a_lnpltb'— ﬁpn

Figure 7: Project Configuration - Adding rhapsody.jar in build path
d) Expand rhapsody.jar and edit the Native library location to point [ . ..]\Share\JavaAPI as shown
below.

£ New Java Project m| *

Java Settings - _3;']_
[l

Define the Java build settings.

# Source = Projects B\ Libraries % Order and Export
JARs and class folders on the build path:

v [ rhapsodyjar | C:\Rhapsody\8.3.1\Share\JavaAPI Add JARs...

& Source attachment: (None)

Javadoc location: (None) GBS RRE

@ External annotations: (None) Add Variable...
-non modifigble
f;? Native library location: C:/Rhapsody/8.3.1/Share/JavaAPl | Add Library..
@ Access rules: (Mo restrictions) [ i, ’
EF Visible only for test sources: No s

= IPE Coctaprsy Vilkrame TlaysSE_1 21 Papmvre

Figure 8: Project Configuration - Native library location

D Attention: **Depending on your Rhapsody installation the /Share folder might be located in on
one of the following locations:

e C:\Users\<user name>\IBM\Rational\Rhapsody\Share\
* C:\<RhapsodyInstallFolder>\Share\
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e) Click Finish>
3. Add an initial Java Class:
a) Right-click the src folder and select New > Class

f% Package Explorer 22
v =% RhapsodyHelpers
B\ JRE System Library [JavaSE-1.8]

= sr-
= R Mew 2% Java Project
Go Into 9 Project..
Open Type Hierarchy & Class
Show In & Interface
b) Set the Package to: com.ibm.rhapsody.helpers
c) Set the Name to: LocateActiveComponentCls
d) Select : Create public static void main
; & Mew Java Class 0 *
| Java Class .
| Create a new Java dass. =
|
Source folder: | RhapsodyHelpers/src | Browse...
Package: | com.ibm.rhapsody.helpers I | Browse...
[ Enclosing type: Browse...
|
MName: | LocateActiveComponentCls I |
Modifiers: ® public O package private protected
[ abstract [ final static
Superclass: | javalang.Object | Browse...
Interfaces: Add...

Which method stubs would you like to create?

public static void main{String[] args)

[J Constructors from superclass
Inherited abstract methods
Do you want to add comments? (Configure templates and default value her

[ Generate comments

Figure 9: Java Class Configuration
e) Click Finish>

= Note: Packages are used in Java in order to prevent naming conflicts, to control access, to make
searching/locating and usage of classes, interfaces, enumerations and annotations easier, etc. Please follow
this convention during the example. Later you can define your own packages convention to bundle group
of related classes/interfaces, etc.
4. Create initial Code:

First we have to connect to the current Rhapsody application. For this we use a function in the Rhapsody library to
get the current Rhapsody instance.
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a) Add the following code to connect to the current Rhapsody instance

IRPApplication rpy = RhapsodyAppServer.getActiveRhapsodyApplication() ;

2 Package Explorer & S = 0lR *LocateActiveComponentClsjava &2
v &% RhapsodyHelpers 1 package com.ibm.rhapsody.helpers;
> =\ JRE System Library [JavaSE-1.8] 2
v B sric 3 public class LocatefActiveComponentCls {

v H com.ibm.rhapsody.helpers
[J] LocateActiveComponentCls.,java
> B\ Referenced Libraries

public static void main(String[] args) {
// TODO Auto-generated method stub

@ W00 =D

(kY

Figure 10: Initial Project Code

= Note: Eclipse might highlight that there are errors:

Multiple markers at this line sodyAppSer
- RhapsodyAppServer cannot be resolved
- IRPApplication cannot be resolved to a type

Figure 11: Unresolved Types Error

5. Solve unresolved types:

IRPApplication rpy = RhapsodyAppServer.getActiveRhapsodyApplication(); =

a) Left click on the & icon to import RhapsodyAppServer in a first step and then IRPApplicationina

second step.

[J] *LocateActiveComponentClsjava 2
1 package com.ibm.rhapsody.helpers;

ERlimport com.telelogic.rhapsody.core.IRPApplication;
‘Bimport com.telelogic.rhapsody.core.RhapsodyAppServer;

5
6 public class LocateActiveComponentCls {
al

8= public static void main(String[] args) {
9 f// TODO Auto-generated method stub

10 IRPApplication rpy = RhapsodyAppServer.getActiveRhapsodyApplication();
11 }

Figure 12: Code after import of unresolved references
6. Calling further Rhapsody API code:

From the connected Rhapsody Application we retrieve its Active Project. From this active project we can get its

Active Component that we're going to locate in the Rhapsody browser
a) Add the following line

IRPProject prj = rpy.activeProject();
prj.getActiveComponent () . locateInBrowser () ;

b) Left Click on the “& icon to import unresolved elements again
¢) Save the project
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Note: This builds the Java Class files automatically:
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C:\TrainingTools\RhapsodyHelpers\bin\com\ibm\rhapsody\helpers

\LocateActiveComponentCls.class

And the folder structure:

WorkSpace: C: \TrainingTools
Initial Class Folder: \RhapsodyHelpers\bin\
Package:com\ibm\rhapsody\helpers

7. Test the Application

Before we integrate and call our application code inside Rhapsody, we will test it in the Eclipse Environment

a) Open Rhapsody and create an initial Project by keeping all settings default

b) In Eclipse press Run O or CTRL+ F11

The code executes and then terminates. The current active Component is selected in Rhapsody

[ LocateActiveComn ponentClsjava &2

1 package com.ibm.rhapsody.helpers;

2

5
6
7
8
1@
ik
2
3
4
5

3= import com.telelogic.rhapsody.core.IRPApplication;

import com.telelogic.rhapsody.core.IRPProject;
import com.telelogic.rhapsody.core.RhapsodyAppServer;

public class LocatefctiveComponentCls {

}

public static void main(String[] args) {
[/ TODO Auto-generated method stub

IRPApplication rpy = RhapsodyAppServer.getActiveRhapsodyApplication();

IRPProject prj = rpy.activeProject();
prj.getActiveComponent().locateInBrowser();

roblems @ Javadoc Dedaration B Console 22 @ Termina

<terminated> LocateActiveCompanentCls [Java Application] C:\Program Files (x86)\Java\jdk1.8.0_17 2\bin\javaw.exe L

Figure 13: Executed and Terminated Eclipse Application

Entire Model View = |

: EIB Project

: [:l Components
ﬁﬁ DefaultComponent

-~ Object Model Diagrams
- Packages

-~ Panel Diagrams

-~ Settings

m

Figure 14: Expanded Rhapsody Browser and its located Active Component
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Task 2: Create Rhapsody Helper Menu Entry

To run the Java program from within Rhapsody environment you can extend Rhapsody by adding a helper which will
invoke your program. In this Task we will add a new Helper Entry in Rhapsody to launch our application from the
Project Menu.

1. Create and add a new Helper menu-entry into the Rhapsody Toolbar:

a) In Rhapsody select Tools->Customize->Helpers
b) In the upcoming Helpers Window select New from the Menu content and type Locate Active
Component

\‘3 Helpers X

Menu content: E:V.hﬁ 1 4

W

T
B AT el L =t i e e s

Helper parameters

Figure 15: Adding new Menu Entry

2. Adding Helpers Parameter:
a) Inthe Command field add the following entry to run Java.

SOMROOT\ . .\jdk\jre\bin\javaw

S3OMROOT is a Rhapsody Variablen and points to RhapsodyInstall/Share folder.
b) In the Arguments fild provide the following information:

-Djava.class.path=SOMROOT\JavaAPI\rhapsody.jar;C:\Rhapsody-Tools

\LocateActiveComponentPrj\bin

-Djava.library.path=$OMROOT\JavaAPI
com.ibm.rhapsody.tools.LocateActiveComponentCls

CLASSPATH is the path that the Java runtime environment searches for classes and other resoirces (*.jar,
* zip,*.class)

c) Inthe Applicable To select Project.

d) Make sure that the Show in pop-up menue check-box is selected before you continue.
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Q;j Helpers x
Menu content: =8 ETII
Create TestCase from Scenario A

Setas Active SDMapping

pdate Description

Rational Rhapsody GatewanADpen

Open Bhapsody Gateway

Fational Rhapsody GatewanyiMNawigate to Origin

Fational Bhapsody Gateway\Synchranize
Explore

Helper parameters

Command: |$OMF§OOT\..\jdk\Jre\bin\ja\faw ‘

“Arguments; | |[-Djava.class path=3OMROOT\JavaAPlhapsody. |
Initial directon: | ‘
Applicable To: |Pr|:|ject V‘
Froject Type: | v‘
Helper Trigger: | v‘
Twpe

Show in pop-up menu

C¥/ait for completion

Figure 16: New Menu Entry - Helpers Paramater
e) Press OK> to close the Helpers Window

. Test the new Helper:

The new helper is available as selection in the project browser.

a) Right click in the project browser and select Locate Active Component.

Entire Model View g%

"'D - Features...
&3 P Add New »
Eﬁe r;.-,,,;-- P Y = YN Y ‘_-:"'4:-;!
Rational Rhapsody Gateway ¥
Locate Activq:gomponent

Figure 17: Launch application through context menu
b) Make sure that the current active component is getting selected.
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1=
&

|  Entire Model View e L
EB Project

2-0 Comonems

g
-0 Object Model Dlaqrams
l -3 Packages

@0 Settings

Figure 18: Current Active Component successfully located
4. Observing the Rhapsody.ini File:
The code for your links is added to the Rhapsody. ini file.

a) Open the Rhapsody. ini File which is located in the Rhapsody Installation folder.
b) Search for the entry Locate Active Component and observe the text underneath.

=l thapsody.ini E3 :
[ [RER] A |

[ [RhapsodyApps]
[ [Spellchecker]

|~.l oy

-\M =m T ey WA S "d g- j S gt.,_,_,,h- pQ 1 ._u.-..-_.f \d‘
e N Gt SkE s : - |

1548 [ReverseEngineeringBrowseHistory]

193 [l [Helpers]

18 numberCfElements=41

namedl=Locate Active Component
MenuStringResourceID4l=

197 command41=30MROOTY . . \jdk\jre\bin\javaw
ag arguments4l=-Djava.class.path=30MRCOT\ JavaAPI\rhapsody.jar;C: \Rhz
a5 initialDir4l=

Hie) isVisibledl=1

isMacrodl=0

isPlugindl=0

206 isSynced41=0

07 UsingJava41=0

08 applicableTo4l=Project

09 applicableToProfiledl=

10 helperTriggersdl=

211 -isPluginCommand41=0

212 [ [BarsLayout-Bar0]

o B F
Pl =]
| L T BT

(TR )

[

L I % T T I o

Figure 19: Extract from rhapsody.ini File- Helpers Entry
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